TECNOLOGíA, INTERNET Y JUEGOS
52 meneos
1375 clics
Este envío tiene varios votos negativos. Asegúrate antes de menear

Mac OS Catalina en un Mac no compatible: Guía de instalación

Apple ha introducido determinadas tecnologías en su software que han hecho que no fuera posible instalar las últimas versiones de su sistema operativo en ordenadores antiguos. En este artículo se muestra cómo realizar la instalación de Mac OS Catalina (10.15) en un Mac en el que apple no permite instalar este sistema operativo de forma oficial.

| etiquetas: mac , macos , catalina , tutorial , no compatible , instalación
29 23 10 K 14
29 23 10 K 14
Mira Borja, un artículo para pobres.
#1 Es bueno, pero piensa que hay mucha gente que programa para iOS y necesitas un Mac aunque sólo sea para compilar, la gracia está que las últimas versiones de Xcode ( el cacharro para compilar ) sólo funcionan en las últimas versiones de OSX y sorpresa! a la Apple Store no puedes subir aplicaciones compiladas previas a la versión X, en resumen, si eres desarrollador de iOS aunque use algún framework multiplataforma como IONIC o React native estás condenado a renovar tu Mac cada cierto tiempo…   » ver todo el comentario
#2 siento joderte el tocho (que por cierto no me he leído), pero mi comentario era un chiste barato.
#3 Si el chiste es cojonudo, solo intentaba subir un poco el nivel del sitio, bueno la verdad es que llevaba dos copas encima y me pongo pedante
#4 Gente que comenta bebida... Esto explica muchas cosas aquí... :-D

PD No en tu caso, es un comentario correcto y que aporta.
#2 En su día me instalé el Mojave en un mac book air del 2011 (con el método calzador que se describe aquí porque supuestamente mi modelo ya no era compatible) y tira bastante bien.

Quitando el tema de la batería que tuve que cambiar hace 1 año o así, el bicho sigue tirando muy bien.
#6 Algo me dice que en mi G4 (PPC) no va a funcionar este método. :roll: :troll:
#12 Es la pena de los G3 y G4. Se han quedado muy atrás a pesar de ser procesadores punteros para la época. A esos Mac no se les puede instalar versiones nuevas de macOS ni tampoco Windows de forma nativa (windows sí se les puede instalar a los primeros mac con Intel). Eso sí... linux creo que les funciona sin problemas. No tengo claro si necesitan una disto específica o directamente funciona cualquier ubuntu o similares (no sé si el kernel de esas distros acepta ese tipo de procesadores.…   » ver todo el comentario
#29 En los G3 y los G4 no se pueden instalar versiones superiores a la 10.5.8 (2009) de OS X ya que con la versión siguiente de OS X, la 10.6 creo, dejaron de dar soporte a la arquitectura PPC, desde ese momento el sistema operativo solo era para procesadores con arquitectura x86.
Un G4 no "puede entender" algo que está programado y compilado para una arquitectura diferente a la suya, al igual que cualquier otro procesador.
A un x86 por ejemplo no le puedes hacer correr algo…   » ver todo el comentario
#12 Mucho pides...
#2 Yo ya me he hartado de darle dinero a Apple, y ahora para el tema que comentas uso un PC con Gentoo Linux y macOS virtualizado utilizando QEMU/KVM. La única pega es que eso me obliga a usar 2 GPUs y 2 monitores, una para Linux y otra para la máquina virtual, por el tema de hacer passthrough de la GPU para que macOS pueda tener aceleración gráfica. Va de puta madre con un mi Threadripper y 2 GPUs RX 580.

passthroughpo.st/
#9 imagino que eres mas pro de AMD, pero para estos casos diria que sale mas a cuenta procesador intel con tarjeta integrada, y pillar tarjeton al que usar mediante pci passthrough.

El caso más habitual es Linux (host) + Windows (guest). Con la integrada de Intel vas sobrado para efectos de escritorio y decodificación de video en Linux. Mientras que el Windows lo usas para juegos, etc. El doble monitor tambien puede ser opcional (ej. si haces passthrough de la tarjeta solo para computo: ML, minar bitcoins, etc.)
#2 Bueno de paso os comparto mis mierdas.
Yo en mi caso tengo un Mac Pro late 2013 osea un equipo que va para 7 años, aunque lo tengo 5, un equipo de gama profesional que me costo un riñon, ahora me hacen la dialisis en el ambulatorio dos veces al mes.
Lo que me hizo pasarme a Hackintosh hace poco, fue que este verano se me jodió el Mac Pro, de repente llego de una semana de vacaciones, que es lo que disfrutamos los automonos, y al volver no arranca. Y lo que fue increíble. Traenos el equipo…   » ver todo el comentario
Puestos a trastear a este nivel, casi compensa más meterse en el maravilloso mundo de Hackintosh Vanilla.

¿Por otro lado qué persona sensata y productiva quiere ponerse una versión del sistema operativo que le deshabilita el 85% de los juegos de steam de 32 bits (por poner un ejemplo), o que deshabilita la suite de adobe buena, es decir la no-cloud?

Mojave >>>>> Catalina a día de hoy.

No hay nada serio que obligue a usar Catalina a día de hoy a no ser que uno quiera problemones gordos por falta de programas profesionales todavía no migrados a 64 bits (o que quizás nunca lo hagan)

EDIT: Antes creo una maquina virtual con Catalina encima de Mojave, que dejar de tener soporte a mis mierditas de 32 bits
#5 yo llevo 6 años con el mismo hackintosh y de maravilla, todo el hw compatible 100%, he actualizado todas las versiones sin problemas incluida catalina 10.15.2,
con catalina las pérdidas más notables han sido winebottler para poder correr apps. de windows directamente pero con vbox 6.0 no supone mayor problema, para mis necesidades que son básicamente desarrollo es la plataforma perfecta.
#15 Dices que especifica que la licencia es para usarse en determinado hardware. ¿Qué hardware? Efectivamente el software sólo es compatible con un hardware específico, pero aparentemente no hay nada en contra de instalarlo en máquinas apple con hardware distinto. Es más ¿Ese hardware se refiere a la placa base? ¿Al procesador? Si tengo un mac pro compatible con una tarjeta gráfica completamente distinta a la que venía de serie ¿Estoy vulnerando la licencia?

Por lo que he llegado a leer, este…   » ver todo el comentario
"Ahora debemos aceptar las condiciones del contrato. Evidentemente sólo le pulsamos «Acepto» después de ler detenidamente durante unas horas todas las condiciones, como cada vez que instalamos cualquier programa ¿Verdad?"

"Apple no termina de creerse del todo que nos hayamos leído bien el contrato, así que la siguiente pantalla es para confirmar de nuevo que lo aceptamos. Parece mentira que desconfíe de nosotros. ¿Hay alguien que le de en «Acepto» sin haber leído todo antes?

…   » ver todo el comentario
Ya que vas a incumplir los términos de la licencia, sale más a cuenta usar hardware de PC y un bootloader tipo Clover...
#35 Pues la manera mas sencilla de montar un hackintosh lo mas estable posible en mi pc actual (un i7 en una placa Gigabyte Z7-D3H con GeForce GTX 1050 Ti)
#25 Un mac mini es algo bastante muy justito de hardware.....
#26 Pero no de precio.

Aparte, es un sistema cerrado. Si el SO es compatible debería ir decentemente.
#25 #26 He escuchado ya unas cuantas veces eso de que los mac mini son peores que el resto de ordenadores de la marca y la verdad es que eso no se sostiene. Sí que es verdad que es un equipo que no se suele renovar con tanta frecuencia como los equipos de sobremesa, pero cualquier Mac Mini está a la altura de cualquier iMac del mismo año de fabricación en cuanto a hardware y velocidad.

Eso sí... no puedes pretender cambiar la gráfica o pincharle componentes como a un sobremesa. Pero en cuanto al rendimiento no debería haber problema. si va tan sumamente mal como dices, es probablemente por otro problema (disco estropeado, problemas con el sistema operativo, etc...).
#25 Tengo en casa un iMac 7.1 del año 2007 con catalina, y te aseguro que de velocidad va perfecto y aún tengo equipo para unos cuantos años más. Al igual que mi macbook del año 2008 que también tiene catalina con este método.

Eso sí... como cualquier ordenador de esa época, si quieres que te vaya fino, toca ampliar RAM y poner SSD. Pero te aseguro que en tareas normales va tan fluído como cualquier ordenador medio que puedas comprar hoy en día (noto el sistema tan fluído como puedo notarlo en un i3 de hoy en día). Vale... no podrás jugar a los juegos punteros del momento, pero navegación por internet, ofimática, multimedia, etc... va de maravilla. Te lo puedo asegurar porque es mi ordenador habitual.
¿Y para qué? Si usando hardware compatible los nuevos SO de Apple hacen tan lentos los ordenadores que es un suplicio intentar hacer cualquier cosa... ¿Cómo va a ir en un ordenador tan viejo que no está soportado?
#16 Pues te pasará a ti.

Enviado desde mi Macbookpro de 2012 con MacOSx Catalina
#21 #18 Un Mac mini de hace un par de años, ni a pedales.

Un estafa de Apple.
#16 con un i7-4790 y ssd normalito corre de maravilla
Que hace una guía para piratear un software en la portada de menéame?
#7 Revisa tu definición de "piratear".
#8 Vulnerar la licencia de uso?
#14 No, son cosas distintas. Y, además, la licencia de uso no es la ley.
#7 Pues nada, si no te gusta la guía aquí tienes un enlace a otra fuente para que te puedas bajar también de gratis este sistema operativo.
apps.apple.com/es/app/macos-catalina/id1466841314
#11 En ese enlace tienes la licencia que especifica perfectamente que la cesión de ese software es exclusivamente para utilizarse en determinado hardware. Si lo instalas en otro estás violando la licencia de uso, es decir, lo estás pirateando.
En mi caso cuento tanto con un iMac original que se quedó en High Sierra (y que muy probablemente no actualice más ya que tiene más de 10 años) y un portátil al que le he hecho hackintosh vanilla con OpenCore (alternativa ligera a Clover) y macOS Catalina.

Además, ya no necesitas un Mac para conseguir un instalador. Te bajas desde Apple una imagen con el instalador online (no tengo la URL a mano) y la grabas en un pendrive. Mano de santo.

Lo más tedioso es cambiarle (si puedes) la tarjeta de…   » ver todo el comentario
#22 Me interesa, algo mas de info?
#27 claro, depende de lo que quieras saber: ¿sobre hackintosh en general o un setup específico?
comentarios cerrados

menéame