105 meneos
423 clics
Aviso automático: Esta noticia tiene varios votos negativos. Asegúrate antes de menear

Obsolencia programada : Aplicaciones AppStore dejan de funcionar en IPhone 3G y anteriores

Las aplicaciones compiladas con la ultima versión del kit de desarrollo de Apple, han dejado de funcionar en IPhone 3G y anteriores. También han ocurrido hechos similares con el IPad. El motivo no es otro que una estrategia de Apple para que la gente compre nuevos dispositivos
etiquetas: obsolencia, programada, software, libre, android, iphone, ipad, apple
usuarios: 95   anónimos: 10   negativos: 31  
78comentarios mnm karma: 128
  1. #1   Que no, que no le han quitado el soporte al iPhone3G, solo han dejado de dar soporte al lenguaje de programación con el cual se le da soporte a las aplicaciones que corren en dispositivos con arquitectura ARMv6
    votos: 9    karma: 78
  2. #2   #1 Vale, pues si puedes dime como puedo instalar Whatsapp, Line, etc. en un Iphone 3G
    votos: 6    karma: 61
  3. #3   No tengo un iPhone y me falta una información clave en esta noticia.

    Dejan de funcionar en todos los iPhones3 o dejan de funcionar en los iPhones3 si la gente no se actualiza el sistema operativo?

    Esa sería la diferencia de una noticia real a haber elevado a categoría de noticia algo que pasa con cualquier dispositivo que use un sistema operativo actualizable.
    votos: 1    karma: 1
  4. #4   #3 Yo tengo un Iphone 3G y no te permiten actualizar el S.O. y cuando intentas descargar cualquier aplicación te dice que solamente funciona en versiones superiores del S.O. Ademas yo tenía instalado Whatsapp, y después de resetear el teléfono ya no he podido volver a instalarlo.
    votos: 21    karma: 191
     *   pmg1 pmg1
  5. #5   #1 bueno llamalo x. El resultado es el que es.
    votos: 5    karma: 56
  6. #6   #4 En ese caso, menuda chapuza de apple.
    votos: 6    karma: 64
  7. #7   Estoy intentando instalar el Call of Duty 3 en el Spectrum de 48K y no hay manera. ¡Odio la malvada obsolescencia programada!
    votos: 40    karma: -88
  8. #8   ¿Obsolescencia programada? Lo cierto es que los smartphones evolucionan muy rápido y se quedan rápidamente obsoletos...pero no porque esté "programado".
    votos: 5    karma: 64
  9. #9   #7 El iphone 3g se lanzó si no me equivoco al mercado en julio 2008 , muy "comparable" el tema si señor
    votos: 24    karma: 239
  10. #10   #9, ¿puedes instalar aplicaciones Android actuales en cualquiera de los primeros móviles Android y que funcionen con buena usabilidad? Mira que sois pesados los antiApple.
    votos: 19    karma: 79
  11. #11   #10 Depende de la aplicación, precisamente ahí está la diferencia, no es lo mismo un "si pide mucho gráfico irá lenta" a un "no va porque no nos da la gana, aunque mira era un programa de mensajería que no requería potencia"

    Una cosa es que evolucionen rápido y que programas 'potentes' no te funcionen, de igual forma que en un móvil de gama baja no podrás jugar a algunos juegos por requerir demasiada cpu, otra cosa es que el compilador directamente no soporte esos móviles con lo que tampoco pueden ejecutar aplicaciones sencillas o poco exigentes en cpu que técnicamente si que deberían poder ejecutar, eso en un aparato de 15 años sería casi que entendible, pero no en uno que no lleva 5 años en el mercado
    votos: 12    karma: 122
  12. #12   #7 ¿Estas comparando la falta de potencia para ejecutar un programa con directamente impedir la instalación cuando el hardware sigue siendo capaz?
    votos: 20    karma: 185
  13. #13   #10 En los de 2008? Claro. Yo tengo un movil un anyo mas moderno que el iphone 3G y todas las aplicaciones funcionan con perfecta usabilidad (Otra cosa es que tarden un poco mas en abrir), estoy seguro que con los moviles de 2008 casi todas las aplicaciones funcionan perfectamente.
    votos: 3    karma: 35
  14. #14   El iPhone 3G salió en 2008, hace 5 años. Y sinceramente, dudo que puedas hacer más con cualquier otro móvil de 2008.

    La obsolescencia programada se refiere a la utilización de determinados componentes que se degradan excesivamente con el uso y finalmente hacen inservible el dispositivo, sin posibilidad de reparación.

    Puedes encontrar ejemplos de obsolescencia programada en planchas, bombillas, impresoras y también productos de Apple (baterías sin posibilidad de sustitución, memorias RAM soldadas a la placa base,...) pero en este caso, se trata únicamente de retirar el soporte de desarrollo a un producto que ha cumplido su ciclo de vida.
    votos: 11    karma: 83
  15. #15   #14 creo que por lo menos con respecto a las bombillas te confundes con «defectuoso por diseño». defectuosas por diseño tb lo son las impresoras.

    obsolescencia viene de "obsoleto", anticuado, tal como su nombre indica. "programada" xq se trata de estrategia empresarial, más que de la capacidad tecnológica del dispositivo.
    votos: 4    karma: 45
     *   --357937-- --357937--
  16. #16   #13 Pues no estés tan seguro, porque estás equivocado. El lanzamiento de Android fue a finales de 2008 y el primer móvil con dicho sistema operativo fue el HTC Dream.

    Haciendo una búsqueda rápida, ni siquiera puede correr Whatsapp con las versiones oficiales de Android: www.htcmania.com/showthread.php?t=421201
    votos: 3    karma: 39
  17. #17   #15 mmm no estoy de acuerdo. Para conseguir una obsolescencia programada, tienes que diseñarlo con defectos (y con consciencia de ellos).

    Te recomiendo este documental al respecto: www.google.es/url?sa=t&rct=j&q=documental%20obsolescencia%20pr

    Hablan específicamente de las bombillas, impresoras y también de Apple, si no recuerdo mal.
    votos: 2    karma: 23
  18. #18   #17 las impresoras llevan un chip para que dejen de funcionar: defectuoso por diseño.
    los iphone dejan de ejecutar whatsapp aunque mucha gente lo tiene y tecnológicamente serían perfectamente capaces de hacerlo, pero la empresa fabricante ha dispuesto un tiempo de uso más reducido. técnicamente se llama "obsolescencia de funcionalidad".
    El otro tipo de obsolescencia, la "del deseo" se encarga apple de planificarla una vez anualmente.

    obsoleto, ta.
    (Del lat. obsolētus).
    1. adj. Poco usado.
    2. adj. Anticuado, inadecuado a las circunstancias actuales.

    he visto ese documental y sé lo que dice ese documental. mi comentario arriba no va de ese documental, sino de hablar con propiedad analizando el significado de cosas que se dan por supuestas e e inducen a confusiones.

    generalmente las fuentes originales tienden a ser más fiables y profundas que las mediatizadas. No te quedes siempre en refritos de periodistas e investiga de dónde tomaron ellos las cosas. aquí está el texto fundado de la estrategia stevejobista: upload.wikimedia.org/wikipedia/commons/2/27/London_%281932%29_Ending_t
    votos: 3    karma: 34
     *   --357937-- --357937--
  19. #19   #10, pues depende, que ya es mejor que un no. Depende del nivel de la api usada por la aplicación. Por ejemplo, whatsapp funcionará en cualquier móvil con android 2.1 en adelante, si tu móvil usa una versión de android anterior no lo podrás instalar. Incluso se pueden poner varias versiones de un mismo programa para distintas versiones de android, o desarrollar para una api vieja pero que ciertas características posteriores sólo funciones en dispositivos que lo permitan. Vamos, que depende del desarrollador y de las actualizaciones que haya recibido el móvil.

    El desarrollador se va a fijar en sus necesidades intentando abarcar el mayor número de dispositivos (es decir, intentará usar una api lo más "vieja" posible) aunque, por lo general, es más sencillo desarrollar para versiones nuevas de android. Por ejemplo, ahora mismo un 0.2% de los dispositivos usan android 1.6, por lo que no tiene demasiado sentido esforzarse en conseguir un programa compatible con esa versión, pero se puede. developer.android.com/about/dashboards/index.html

    El mío viejo salió con android 1.5 en 2010 y fue actualizado a 2.1 oficialmente, a 2.2 extraoficialmente, por eso jamás me volveré a comprar un Samsung cuyas actualizaciones dependan de Samsung (ahora tengo un Samsung Galaxy Nexus y tan feliz, las actualizaciones dependen de Google).
    votos: 2    karma: 24
  20. #20   #16 pues a ser que no, yo tengo un htg dream, o htc magic como se llamo por aqui, y tiene whatsapp, endomondo y facebook, tiene android 2.2.1 OFICIAL y funciona lentooooo pero funciona
    eso si, no se me ocurriria ponerle line, no pq no funcione, si no pq la bateria no me duraria ni 1 hora :-P
    votos: 1    karma: 16
  21. #21   Hombre...si no es obsolescencia programada que actualices el móvil con un nuevo SO y que éste te ralentice el teléfono hasta dejarlo como un ladrillo...
    Y ademas las aplicaciones dejan de funcionar en ese mismo móvil por culpa de la actuazación.
    Si, yo tuve un Iphone 3G y hablo sabiendo que Apple se las ingenió para que el móvil degenerara en algo así como una patata con bonita pantalla.
    votos: 6    karma: 66
  22. #22   ¿Qué pintan como etiquetas "libre" y "android"? Pero, ¿el microartículo este plagado de negritas y mayúsculas no versaba sobre iPhone?

    Y, por cierto, como desarrollador nada te impide tener instalada la versión 4 de xcode y compilar con ella para iphones antiguos como el 3g. Tampoco nada evita a, por ejemplo, whatsapp a tener una versión publicada en la app store para iphone 3g más allá de su propia voluntad.

    Simplemente XCode ha dejado de soportar una arquitectura de hace 5 años. Programo desde hace 20 años y es lo que suele pasar... nuevas versiones de un entorno de desarrollo habitualmente añaden nuevas arquitecturas y abandonan otras. Como digo, nada evita que desarrolles y compiles con una versión más antigua. Apple no te obliga a usar la última versión de XCode para publicar en la App Store.
    votos: 16    karma: 128
  23. #23   #16 Si te fijas dicen que no funcionaria por el sistema operativo, que en un movil android se puede cambiar (Yo mismo lo he hecho para que algunas nuevas aplicaciones funcionen y poder meter mas aplicaciones en la tarjeta SD, no es dificil, yo no tengo conocimientos de eso, es seguir unos pasos). Asi que si, funcionaria.
    votos: 0    karma: 7
  24. #24   #18 Mira, te has sacado de la manga el concepto "defectuoso por diseño", cuando de existir, seguría siendo un concepto ambiguo (¿intencionado o inintencionado?). Así que no creo que tu interés sea el de hablar con propiedad y evitar inducir a confusiones.

    Si buscas información al respecto, verás que algunos de los dispositivos que más se mentan en relación a la "obsolescencia programada" son precisamente las bombillas (por ser de los primeros productos en implementar este concepto), las impresoras (por ser el ejemplo más notorio) y los,productos de Apple (como exponente de los dispositivos electrónicos de los últimos años).

    Entiendo que estés convencido de tu posición, pero ya te adelanto que es porque entiendes por "defectuoso por diseño" el concepto denominado en realidad "obsolescencia programada". Y no por mí, sino que ya se definió así hace casi 100 años y desde entonces se sigue usando.
    votos: 0    karma: 6
  25. votos: 1    karma: 16
  26. #26   #21 No lo actualices. Nadie te garantizó actualizaciones indefinidas para el teléfono cuando te lo compraste.
    Eso no es obsolescencia programada lo pintes como lo pintes. ¿Te funciona bien con la versión de iOS que traía de serie? ¿Si? Pues no es obsolescencia programada. El término significa lo que significa. No podemos usarlo a nuestra conveniencia modificando su significado.

    Yo quisiera instalar en mi viejo alfa 33 las actualizaciones para la centralita de mi 159ti pero nada, que no hay manera. Mamones de Alfa Romeo, que hacen eso de la obsolescencia programada con mi coche... Me voy a cambiar a Seat a ver si aquí si puedo actualizar un 127 con los mapas de inyección del último León, aunque sospecho que el hecho de que el 127 llevara carburadores en lugar de inyección va a ser un problema
    votos: 9    karma: -34
  27. #27   Las aplicaciones instaladas """funcionan""". Si requiere actualizar para funcionar, no podrás ergo no podras utilizarla mas.
    Si te la borras y la quieres re-instalar, en el APP Store solo estan las ultimas, así que tampoco podrás instalar la mayoría.
    votos: 2    karma: 23
  28. #28   #23 Según dicen en ese foro, la versión de SO máxima soportada es 1.6 y necesita al menos la 2.1.

    Si se puede rootear el teléfono para actualizar el teléfono es indiferente, ya que deja de ser oficial el soporte. Aunque no discuto que sea sencillo.

    Lo que pretendía decir es que esto ocurre con todos los móviles. Viene a ser una no-noticia,
    votos: 2    karma: 28
  29. #29   No olvidemos, que el hardware del primer iPhone y el del iPhone 3G es el mismo.
    votos: 2    karma: 27
  30. #30   #26 Imagina que compras una Nesspreso, en 2008, y ahora dicen, ya no fabricamos capsulas, ¿que haces con la cafetera?, Apple hace lo mismo al eliminar el soporte de ARMv6 en el XCode, no dejan vías para actualizar aplicaciones como el whatsapp que pueden seguir funcionando sin problemas. Nadie pretende instalar un Autocad en un iPhone3G, ni poner el último juego de moda, con gráficos 3D, solo quieren poder usar su móvil como hasta hace un mes.
    votos: 7    karma: 76
  31. #31   #26 ¿Intentabas ser gracioso?
    Yo no le veo la gracia a que la gente se compre dispositivos que se vuelven obsoletos en cero coma.
    Que se actualice el SO de un teléfono y que inmediatamente deje de funcionar con la misma velocidad, que se atranquen las apps, que tenga cuelgues, etc...tú lo podrás llamar como quieras, yo lo llamo obsolescencia programada porque es una forma subrepticia de dejar el teléfono como un ladrillo y que la gente que no tiene conocimientos de como volver a la antigua versión acaba comprándose otro.
    ¿Que no se te rompe? Pues claro. Físicamente no deja de funcionar, pero no rulan las aplicaciones como al principio.
    Y eso no es culpa de hardware sino de la actualización maliciosa de Apple que deja a sus Iphone como ladrillos.
    Así que...a comprarse otro.
    ¿Eso no es una forma diferente de obsolescencia programada?
    votos: 3    karma: 39
  32. #32   #28 No ocurre con todos los móviles, a Whatsapp le interesa la gente que tiene iPhone3G, al igual que a Facebook, pero Apple cierra las puertas a esas empresas para ofrecer actualizaciones. Aun hay muchos iPhone3G funcionando y es una manera poco ética de sacarlos del mercado.

    Lo siguiente será aceptar por EULA que Apple te detone el móvil.
    votos: 4    karma: 40
  33. #33   El problema es que Apple tiene una aplicación que los programadores usan para desarrollar programas (Xcode). En su última versión exige ya que el sistema operativo del iPhone/iPad/iPod sea iOS 4.3 o superior, es decir, dejan fuera el iPhone 3G y anteriores (que solo se pudieron actualizar a la versión de iOS 4.2.1)
    votos: 2    karma: 36
  34. #34   Se pongan como se pongan, esto es una cabronada de Apple. Un teléfono de 500 pavos no puede dejar de funcionar, por falta de software, en cuatro años. Digan lo que digan. Es una estafa. Sobre todo, a los que pagaron por whatsapp, que no siempre fue gratis.
    votos: 3    karma: 46
  35. #35   #34 Pueden decir misa, pero lo que tu dices es una verdad como un puño
    votos: 3    karma: 46
  36. #36   #24 sólo leí hasta tu primera frase por que «mira te has sacado de la manga un concepto» significa: «estas son las 4 cosas que me han dicho y he aprendido de memoria y quién te crees tú para venir a sacarme de mi cancioncilla porque me lo trastocas todo, de verdad, ¿quién te crees que eres para inventarte conceptos que la televisión no me ha impuesto«.

    de verdad que Einstein tenía razón con lo del universo infinito ese.

    Yo y cuarenta millones de resultados en Google nos lo hemos sacado de la manga. pero eso es lo de menos.

    no sólo porque una idea resulte nueva o chocante debería una persona de inteligencia media o media-alta rechazarla sin pensar.

    www.google.de/search?client=safari&rls=en&q=defective+by+desin096503&biw=1362&bih=700&bs=1

    esta conversación ha terminado: la vida es muy corta para perder el tiempo discutiendo con cualquiera que se cree que saber teclear significa saber escribir.
    votos: 0    karma: 6
     *   --357937-- --357937--
  37. #37   #2 Ahora ya no puedes instalarla de una forma normal. Tendrás que buscarte la última versión compatible y hacerte un apaño para instalarla.

    #1 #3 #4 Ha habido dos problemas. El primero es que el iPhone 3G hace tiempo que dejó de recibir actualizaciones del sistema y que las últimas versiones del entorno de desarrollo de Apple abandonan de "serie" el soporte de estos teléfonos. Digo "de serie" porque se pueden hacer algún apaño para recuperarlo.

    El segundo problema son las actualizaciones de las aplicaciones. Por la restricción anterior la mayoría de los desarrolladores sacan sus aplicaciones sin soporte para el sistema del iPhone 3G y si intentas actualizar desde el teléfono te dice que no es posible. Pero aquí viene el lío, y es que si actualizas desde el ordenador (desde iTunes) si que te deja y luego cuando vas a sincronizar te dice que la aplicación no es compatible con tu teléfono. Entonces el usuario en caso de querer borrar una aplicación y volver a instalarla, o restaurar su teléfono se encuentra con que todo lo que haya actualizado desde el ordenador no va a ser compatible con su teléfono (aplicaciones por las que puede haber pagado) y de ahí vienen las quejas.

    Whatsapp, por ejemplo, anunció que dejaba de dar soporte a la aplicación del 3G y nos estuvo avisando todo diciembre. En día 2 de enero canceló el servicio y al día siguiente lo volvió a activar sin que se sepa el motivo (supongo que por las quejas).

    #34 El teléfono funciona sin problemas, son las aplicaciones de terceros las que han dejado de funcionar. Apple tiene algo de culpa, pero son los desarrolladores los que no están haciendo sus deberes. Y yo soy un usuario de un 3G.
    votos: 5    karma: 53
     *   Xtampa2 Xtampa2
  38. #38   #30 ¿Me estás diciendo que no puedes utilizar un iPhone 3g? El mío funciona correctamente. No lo actualicé demasiado. No pretendo que con actualizaciones de software se multiplique exponencialmente las capacidades del hardware.

    ¿Ya no fabrican cápsulas apps para el? Como ya expliqué anteriormente, se puede seguir programando, compilando y subiendo a la store apps con XCode 4, que si que compila sin problemas para 3g (otra cosa es que el desarrollador de la app pase de hacerlo).

    #31 No. Trataba que ponerte un ejemplo muy muy chorras. Conozco las limitaciones del hardware que compro. El fabricante no me promete en ningún caso que podré utilizar en el versiones de dentro de 5 años del sistema operativo, ya que el hardware permanece invariable pero el SO ha de ofrecer las correspondientes mejoras para el hardware nuevo.

    Nadie te obliga a comprarte nada. Puedes utilizar el 3g (mi mujer lo hace a diario y no es un ladrillo en absoluto) o comprar un hardware superior para disfrutar de las mejoras de los últimos SO. Todo depende de tus necesidades o apetitos.

    La obsolescencia programada es lo que es. El término está bien definido. Si quieres utilizarlo para describir otra situación, libre eres, pero no pretendas que esté de acuerdo con tu propia definición del mismo.
    votos: 2    karma: 30
  39. #39   Yo si creo que se puede hablar de obsolescencia programada por el siguiente detalle . Si un paquete que funcionaba con IOS 4 lo actualiza y pasa a funcionar con el 5 , la Apple Store todavía debería ofrecer una versión anterior para los dispositivos a los que Apple les niega laactualizacion de IOS. No Tiene ningún sentido que mientra que Apple te capa la actualización de los tampoco te permita instalar una versión de la aplicación anterior que si que era compatible con tu aparato
    votos: 3    karma: 35
  40. #40   #38 las nuevas APPs no pueden fucionar en 3G. Algunas que funcionaban antes, han dejado de hacerlo. Es un engaña bobos que dejen de funcionar cosas que antes lo hacian. Otra cosa es que alguien quiera juegos 3D de la hostia o similar. En ese caso que sean consecuentes y compren un cacharro nuevo.
    La culpa es de APPLE por supuesto.
    votos: 4    karma: 48
  41. #41   #36 Lo primero que hice antes de contestarte fue precisamente buscar "defectuoso por diseño" y "defective by design". Y esto es lo que se dice alrespecto:

    Defective by Design is an anti-DRM initiative by the Free Software Foundation. DRM technology, dubbed "digital restrictions management" by opponents, ...
    en.wikipedia.org/wiki/Defective_by_Design

    Personalmente, me parece curioso que en un mismo comentario hables de tu incapacidad para leer tres párrafos seguidos sin cansarte y a continuación trates de hacerte pasar por una persona inteligente y libre del yugo mediático, acusando a los demás de poco menos que pobre diablo.

    PD: Revisando el hilo y viendo tu nick y fecha de registro, veo que la culpa es mía por haberte hecho caso.
    votos: 1    karma: 15
  42. #42   #14 Impidiendo a los usuarios descargar sus aplicaciones u obtenerlas por otroos medios. Es muy grave.
    votos: 1    karma: 16
     *   Kherom Kherom
  43. #43   #37 algunas aplicaciones son imposibles de usar, ni con apaños ni nada. Si te refieres a usar un Jailbreak, eso no vale ya que eso solo te deja instalar cosas fuera del APPStore, pero si una aplicación tiene una versión nueva y las antiguas no van (ejemplo WhatsAPP) no se que quieres que se haga. Y actualizar el IOS es imposible, no hay apaño posible, y si lo hay iluminanos a todos como realizar dicho apaño.
    votos: 1    karma: 24
  44. #44   #40 A ver... Ya lo he explicado dos veces, pero voy a hacerlo una más:

    La última versión de XCode no permite compilar para 3G, pero (y este pero es muy importante), siempre puedes escribir la app y compilarla utilizando XCode 4 y subirla a la app store, de modo que si el programador quiere... no tiene más que utilizar una version más antigua del entorno XCode para hacerla funcionar en 3G. Apple se ha limitado a retirar (por el motivo que fuere) el soporte a una arquitectura antigua de la última versión de XCode. Whatsapp, por ejemplo, va de víctima y dice que es que Apple se lo impide, pero eso es falso.
    votos: 2    karma: 31
  45. #45   #44 Yo no tengo por qué depender de si el programador quiere o no actualizar, si Apple sólo me deja instalar de su tienda, deberá mantenner en ella la última versión, o liberar el SO y dar un tiempo para que me descargue instaladores de todo el software.

    En mi 5800 sigue funcionando WathsApp sin problemas.
    votos: 1    karma: 18
     *   Kherom Kherom
  46. #46   #43 Pero hay que distinguir entre el desarrollador y Apple. Apple bien cierto es que a la que puede va poniendo zancadillas para ir obligando a la gente a renovar hardware, pasa con el iOS y pasa con el Mac OS X. Soy usuario de Mac desde el 90 así que algo puedo contar al respecto. No le voy a quitar culpa de nada, pero en este caso la zancadilla que ha puesta es bastante salvable.

    #45 Que una aplicación vieja deje de funcionar, como fue el caso de WhatsApp, es porque el desarrollador elimina la posibilidad de que siga funcionando, sus servidores dejan de "hablar" con ella. Apple no tiene nada que ver y aquí no hay apaño que valga, de nada te vale conseguir la aplicación vieja porque aunque en el teléfono se ejecute luego no va a funcionar como debiera.

    En cuanto a apaños me refería a los casos en los que la aplicación vieja sigue funcionando pero ya no es descargable porque la actualización no es compatible. En ese caso se puede instalar de nuevo en caso de ser necesario consiguiéndola por cauces no oficiales o de un backup.

    #44 De hecho se puede apañar la última versión del Xcode para que compile para ambas arquitecturas.
    votos: 2    karma: 30
     *   Xtampa2 Xtampa2
  47. #47   No no, según los listos de turno lo de la obsolescencia programada son magufadas y conspiranoias. Porque ellos lo valen.
    votos: 1    karma: -1
  48. #48   FALSO. No es un problema de Apple.

    El problema de WhatsApp es otro. Al hacer la autenticación, la aplicación de Whatsapp envía, entre los datos, la versión instalada. Ese dato es procesado junto con el resto en los servidores de Whatsapp Inc y si no es la última versión o la penúltima, devuelve un error que hace que en la pantalla salga el registro o la necesidad de actualizar.

    La aplicación sigue funcionando en iOS. Es más, se siguen recibiendo notificaciones por push.


    No estamos ante un fallo de Apple, sino de Whatsapp Inc. En algún momento incluyeron esa parte del código para evitar que hubiera gente con versiones desactualizadas. Eso es algo que puede ser entendible hasta cierto punto, pero solo en ciertas condiciones. Por ejemplo, si hay un cambio de cifrado, de la encriptación, etc. Pero es que el protocolo y el modelo de datos siguen siendo el mismo en la versión 2.8.4 que la 2.8.7. Desde hace varias versiones el software de los servidores debería de haber cambiado y no contemplar el uso de las dos últimas versiones, sino de versiones posteriores al cambio de cifrado que hubo.

    Hay muchas aplicaciones de comunicación en iOS que siguen funcionando sin actualizarse desde hace tiempo para iPhone 3G. Basta con saber desarrollar con compatibilidad para versiones y/o dispositivos más antiguos y solamente dejar de dar soporte cuando es estrictamente necesario. en el caso de una aplicación de comunicación personal, cuando se comprometa la seguridad. ¿Que mi versión de la aplicación no es capaz de agregarme a un grupo de más de 15 personas? Pues a la hora de agregarme el servidor dar un error y dice que no puedo ser agregado. ¿Que no tengo más botoncitos en la interfaz? Pues bueno, me será más difícil comunicarme o no podré aceptar un envío de una funcionalidad que no soporta mi versión, pero la comunicación (texto plano), debe seguir funcionando mientras no se de ese cambio debido a que se compromete la seguridad.


    Y era tan tan tan claro, que desde ayer Whatsapp vuelve a funcionar a todos aquellos que no desinstalamos la aplicación de nuestro iPhone 3G.

    Lo que no es de recibo es

    a) Las mentiras de Whatsapp Inc echándole la culpa a Apple donde no la tiene.
    b) La incapacidad de Whatsapp Inc de darse cuenta de que ésto iba a ocurrir.
    votos: 15    karma: 147
  49. #49   Seguid comprando mierdas de Apple.

    Seguid.
    votos: 6    karma: 72
  50. #50   #27 Yo por eso tengo una carpeta en el PC con las APIs que me funcionan, y las voy sustituyendo por las versiones nuevas cuando funcionan bien, asi apple puede hacer lo que le de la gana, que yo seguire teniendo las aplicaciones
    votos: 0    karma: 7
  51. #51   #46 #48 A mí, frente a lo que decís, Whatsapp no me va, me caducó la versión y no me quieren mandar el código de activación (Lo sentimos, su versión de la aplicación se caducó. Por favor, descargue la última versión de la App Store.
    Tengo la versión 2.8.4, la última soportada para iPhone 3G, y me dice que caducó la versión como ya les había pasado a 2 familiares míos a los que les tuve que hacer jailbreak para instalar la 2.8.4(les había caducado su versión) hace un mes pero ahora les volvió a dejar de ir, como a mí.
    Tenéis alguna solución para este caso?

    En este caso es un problema exclusivo de Whatsapp y no de Apple. Las notificaciones Push van a parte ergo sigo recibiéndolas.
    votos: 2    karma: 29
  52. #52   #50 si la versión aplicación que guardas deja de funcionar en el lado del servidor no vale tu técnica.
    votos: 0    karma: 9
  53. #53   #4 Has probado con esto? www.whited00r.com/
    Permite instalar un iOS 6 en cualquier dipositivo antiguo. No sé que tal funciona, el otro día estuve tentado de probarlo en un viejo iPhone 2G pero al final no me puse.
    votos: 0    karma: 9
     *   javipe javipe
  54. #54   #53 eso emula los añadidos que mete IOS 6, pero no es el equivalente a tener IOS 6. Es digamos un IOS antiguo "tuneado". Por supuesto, no permite correr aplicaciones para IOS 6.
    Es como cambiar el aspecto de un Windows 95 para que se parezca a Windows 7, pero no es Windows 7 ni admite sus programas.
    votos: 1    karma: 21
  55. #55   #4 Solución: jailbreak e instalar la versión anterior a tu error. Suerte.
    votos: 0    karma: 11
     *   Jiraiya Jiraiya
  56. #56   #52 Ya, pero menos es nada, sino fuera por esto, mi iTouch no valdria ni para ver videos avi.
    (que conste que salvo el ipod video de 80Gb que uso de jukebox y que sigue cumpliendo como el primer dia, todo lo demas de apple me lo han regalado)
    votos: 0    karma: 7
  57. #57   #51 Ya no sé. A mi me funciona pq no toqué la app. Hay quien dice que solo te funciona si estás registrado en los servers de whatsapp inc, es decir, si compraste la app por la App Store, te llegó el sms, no crackeaste la app etc. y claro, si no has reinstalado la app pasado el momento en qeu dejó de funcionar.

    Si fuera ese el caso y la razón de no funcionar, estaríamos ante otro grave error de whatsapp inc. Ya qeu funciona, deja que tdos los que lo hagan legal (te pagan la app), les funcione. Aunque se la reinstalen después. Otra cosa es intentar evitar los que se la instalen de cydia/installous u otras plataformas si se puede.
    votos: 0    karma: 10
     *   MrQeu MrQeu
  58. #58   #48 Y que los jodios de WhatsApp no sueltan prenda. Ya podían aclarar un poco las cosas, simplemente reconocer que les han llegado muchas quejas y que han decidido rectificar. Pero nos tienen en ascuas esperando a que vuelvan a cancelar el sistema.

    Yo soy uno de los que tiene un 3G y que ha recuperado la funcionalidad de WhatsApp. No la desinstalé cuando dejó de funcionar y simplemente tuve que volver a identificar el número de teléfono cuando me lo pidió. Cuando no funcionaba me lo rechazaba diciendo que debía actualizar a la versión más nueva. #51, ni idea de por qué a ti no te funciona, salvo que sea como dice #57 y la aplicación no la comprases en su momento.
    votos: 0    karma: 8
  59. #59   soy de los afectados y me he pasado a android.

    Yo lo que tengo es un 3GS con jailbrea con 4.2.1 porque tlfnica no me lo desbloqueaba para irme a pepephone con el 3GS y hace falta 4.3 por lo que me tocaria nuevo jailbrear nueva bios blalblab ay estoy harto directamente me he pasado a un galaxy.
    votos: 3    karma: 38
  60. #60   Dentro de 5 años cambio mi iPhone 5 por el último modelo y listo.
    A pastar.
    votos: 1    karma: -3
  61. #61   Yo también tengo el iphone 3 y me pasa lo mismo. Estoy esperando por el Nexus 4 y le van dar por el saco al teléfono y a la compañía que me tienen hasta los cojones.
    votos: 3    karma: 43
  62. #62   #58 #57 Había tenido que instalar por Jailbreak la versión de Whatsapp 2.8.4 cuando ya no estaba en la App Store ya hace un tiempo, en su tiempo sí la compré, pero me temo que ya será imposible restaurar a esa versión :-S
    votos: 1    karma: 16
  63. #63   Anda, pues ahora resulta que sí funciona de nuevo el whatsapp
    votos: 0    karma: 15
  64. #64   Eso os pasa por utilizar sistemas operativos inferiores.

    Con el SDK de Android puedes compilar para todas las versiones.
    votos: 2    karma: 28
  65. #65   #25
    #16
    #20 Yo tengo el móvil HTC TATTOO y se quedó en la versión de Android 1.6. Es decir, sin Whatsapp ni nada.

    #64 Pues para la 1.6 no hay nada.
    votos: 0    karma: 12
     *   DaniTC DaniTC
  66. #66   'Resumiendo, tengo un iphone 3G y nadie da una solución para arreglarlo. He probado diversas opciones y no han funcionado. Mi caso es que no me hequedado sin backups tras tanto toquetear para intentar arreglar que funcionara con un nuevo IOS, y ahora tengo el movil sin el wassap :-( Solución para poder instalar la versión 2.8.4 de nuevo o la que sea compatible con IOS 4.2.1??
    votos: 0    karma: 9
  67. #67   #65
    Díselo entonces a los de Whatsapp, porque desde luego por el Android SDK no es, al contrario de la versión para iOS que según parece el último SDK ya no te permite compilar aplicaciones para el iOS necesario.
    votos: 0    karma: 8
  68. #68   #4 El problema es que cuándo has ido a instalar la nueva versión de WU esta ya esta estaba actualizada para Iphone3G.
    votos: 0    karma: 8
  69. #69   Arreglado el problema: Whatsapp tras unos días ha rectificado y permite usar dicha versión 3.8.4 antigua compatible con ios 4.2.1. Si alguien la tiene desinstalada, via jailbreak+openssh o culquier manera puede instalar :-)
    votos: 1    karma: 23
  70. #70   #14 #8 #17 y muchos más: La obsolescencia programada es la determinación, la planificación o programación del fin de la vida útil de un producto o servicio.

    El caso más habitual es: uno de los aparatos electrónicos de uso habitual falla. Cuando el dueño lo lleva a reparar, en el servicio técnico le dicen que resulta más rentable comprar uno nuevo que arreglarlo.

    Aunque sólo sea el fusible, esa forma de actuar también es obsolescencia programa.
    votos: 0    karma: 8
  71. #71   No soy defensor de Apple, pero tengo un móvil con Android Gingerbread y no puedo instalar buena parte (diría que la mitad) de las aplicaciones del Google Play. Algunos sacan cualquier excusa para criticar.
    votos: 0    karma: 8
  72. #72   #37 A ver, que me enterado solo a medias, porque la mayoría de los comentarios están escritos en un idioma que no domino, lo siento...Tengo el 3GS y no tuve ningún problema en actualizar el software nuevo cuando salió, todas las aplicaciones funcionan bien y se actualizan con normalidad (Whatsapp incluido). La verdad es que pensaba tirar con él un tiempo más (bastante a ser posible) ¿Estáis hablando del 3G o también del 3GS? Siento si la pregunta es tonta, de esto no sé nada, solo lo uso.
    votos: 0    karma: 6
  73. #73   #10 "¿puedes instalar aplicaciones Android actuales en cualquiera de los primeros móviles Android y que funcionen con buena usabilidad?"

    Nop. Pero como verás en #4 el problema no es ese. El problema es que aplicaciones que antes funcionaban, ahora ya no.

    Soy desarrollador de Android, y una cosa que he visto es que si sacas versiones nuevas de una aplicación aún así te mantiene las versiones viejas para dispositivos antiguos.
    votos: 1    karma: 19
  74. #74   #44 "de modo que si el programador quiere... no tiene más que utilizar una version más antigua del entorno XCode para hacerla funcionar en 3G"

    Soy programador de XCode y NUNCA haría esa burrada que acabas de decir. Para empezar sin la nueva versión de XCode no puedes adaptarte al iPhone 5 (a su pantalla más alargada). Es decir, las aplicaciones funcionan en el, pero no están optimizadas. Igual con cincuentamil características nuevas de XCode e iOS6.

    Nadie va a hacer esto que sugieres.
    votos: 0    karma: 11
  75. #75   #72 en el 3G, el 3GS todavía funciona bien y aún le queda cuerda para rato ya que soporta IOS 6, pero te encontrarás con un problema en 2 o 3 años cuando decidan dejar de soportar IOS 6.
    votos: 0    karma: 10
  76. #76   #74 Me has malinterpretado. No, no digo que se deba programar con una versión antigua de XCode. Lo que digo es que si Whatsapp se excusa en que con la última versión no puede compilar una versión para iPhone 3G, bien puede hacer una versión optimizada para iPhone 5 y iOS6 y compilar otra versión "old" para 3G con un XCode antiguo (aunque lo suyo sería volver a añadir soporte para arquitecturas antiguas al nuevo XCode, que se puede).

    Yo tampoco haría esto. Mis apps hace tiempo que no soportan versiones más antiguas que iOS5 (salvo excepciones) ya que suelen hacer uso de características que no están disponibles en sistemas o terminales antiguos , pero tampoco pongo como excusa que Apple no me deja compilar para su arquitectura.
    votos: 1    karma: 18
     *   Haze Haze
  77. #77   #75 Gracias.
    votos: 0    karma: 6
  78. #78   #76 Además mejoras en el compilador pueden incluir otras cosas a soporte de la pantalla de IPhone 5, como medidas de seguridad.

    #7 Pues no es lo mismo instalar Call of Duty en el Spectrum que "de repente" La abadía del crimen te deje de funcionar ;)
    votos: 0    karma: 9
comentarios cerrados

menéame